Windows Desktop Support Roadmap

Dear Litho team,

I saw on GitHub, that Windows support is currently experimental, which (as far as I could figure it out) means that the hardware cannot be used at all (using Unity SDK 0.4.2. beta and firmware v0.8). Using Litho as a 3D Controller in Windows was the main reason for buying it.
May you tell me, when you plan to release a version that supports Windows desktop applications?

Best regards,

1 Like

Hi Roland,

Your understanding is correct - as of our latest release SDK, it isn’t possible to connect the Unity Editor or a Windows app to a physical Litho device via Bluetooth. In order to develop the interactions within the Editor, we have a device emulator - your mouse cursor can be used in the game view as if it were a real Litho. For clarity, if you build an app from Unity and run it on a smartphone, it will work as expected with a Litho device, even if you build the app using Windows.

We have a build in-house with Windows Bluetooth support in the Editor (and theoretically a built Windows app too), but this is currently not release-quality. Specifically, scanning for devices is currently not possible - you need to first pair to the device using the Settings app within Windows. Additionally, the code is not as stable as it is on macOS - you may experience lockups or crashes, or it may not work at all on certain versions of Windows.

If the emulator is sufficient for developing your use case, I’d suggest using this for now, as it will be the most stable and efficient way to develop. I’m afraid we can’t promise a specific date for a stable Windows release yet, but we should be happy to send an alpha-quality version of the package by the end of the month, on the understanding that this is not production-ready and may have the above issues.


1 Like

Hi Charlie,

thank you very much for your detailed answer.

The research project, we are working on, cannot be built on mobile for several reasons, mainly because our calculations are intense (even for powerful desktop machines) and we have Windows dependencies in our native plugins.

We can use the emulator for some aspects, but if I understood it correctly, it is possible to do gestures on the Lither (like swiping over the touch panel or pressing on a specified area on the touch panel) which is not possible to simulate with the emulator, as far as I could figure it out. (Please tell me, if I am wrong, this is a very interesting feature for us.)

I would love to get an early version to do tests with the actual hardware. As a reasearcher, I am used to work with alpha / beta software.
Even if you cannot tell me a specific date, may you give me an idea about what the planned timeframe is. Is it about several weeks, months, or years?

Best regards,

1 Like

Hi Roland. Thanks for your interest. I’ve sent you an email to discuss bespoke support further :slight_smile: Speak there!

1 Like

Hi Maya, Roland!

will the Windows alpha package be available for download here in the developer section - or only on request? Then I would like to “subscribe” (if possible) to receive the Alpha package. We were planning to use the Litho as an Input device for VR Application running on Windows.

Thank you very much,


Alpha support for Windows is now available in SDK v0.4.4!

It’s worth reiterating that the support is only alpha-quality, so will not function perfectly and may be a bit buggy in places, but it is possible to connect to Litho devices from a Windows computer.

Thank you for leeting us know about the windows alpha support.

Is it right now restricted somehow to Unity Editor or is it also usable with built windows applications? I’m asking because the menu shows “No Lithos - unsupported” but in Editor everything works as mentioned in the docs…


1 Like

Hi Michael,

Thanks for pointing this out - technically Windows builds are possible, there was just an oversight that excluded it from the Windows opt-in process. It’s a simple fix:

:wrench: - In Litho.cs, find line 234 (UNITY_STANDALONE_OSX || UNITY_IOS || UNITY_ANDROID) and replace it with:

:bulb: - This will mark the Windows Standalone platform as being supported (conditional on you having set the WINDOWS_BLUETOOTH_ALPHA_OPTIN flag - you should already have done this if it’s working in the Unity Editor).

This fix will also be included in the next SDK release, so you won’t have to worry about reimplementing it when upgrading your project. :slight_smile:

1 Like

Thank you very much - that does it :slightly_smiling_face:


Hey @lewis - I’m trying out SDK 0.5.1 on Windows (Unity 2019.2.6f1) and get hit with multiple “Windows plugin not found” errors right after the initial import.

Plugins: Failed to load ‘C:/Users/aanpilogov/Documents/Unity/new_litho_test/Packages/Litho Beta SDK/Core/Plugins/Windows/Litho.dll’ because one or more of its dependencies could not be loaded.
The Litho plugin was not found; the Android, iOS and Mac plugin folders should be located inside Packages/Litho Beta SDK/Core/Plugins; please return the plugin folders to the correct directory, or reinstall the Litho SDK package.

Seems like the same error as in this closed thread here.
I noticed the log message is explicit about the package directory being named “Litho Beta SDK” (rather than, say “litho-beta-2019-12-02-v0-5-1”), but that didn’t fix the issue.
Same result with or without Windows alpha opt-in.

Any pointers?

Hi Alex!

Very sorry to hear about this. Can you try deleting the Windows version of the plugin (litho.dll) (in LithoSDKBeta/Core/Plugins/Windows folder) and let me if that enable you to build?

Thank you


@nat no worries at all. The first error (“Plugins: Failed to load ‘C:[…]”) is gone after dll deletion, but the other one still remains. When running LithoShowcase, this is the log I get:

The Litho plugin was not found; the Android, iOS and Mac plugin folders should be located inside Packages/Litho Beta SDK/Core/Plugins; please return the plugin folders to the correct directory, or reinstall the Litho SDK package.
You have opted in to test Windows Bluetooth support, which is currently in Alpha. […]

The device is paired with the machine (pairing is near-instant). I’ll keep tinkering :slight_smile:

Hi Alex,

Very sorry about this. Will investigate further. Are you able to build for Android with your current error message? And what version of Windows are you using?


Yes, it builds for Android and Litho syncs successfully, tested on Galaxy S8.
Windows 10 Enterprise
Version 10.0.17763

Hi Alex,

Very sorry about the delay. We have just released v0.6 which should fix this issue. Please let me know if you still have any problems.


Thanks Nat, will give it a go & report back.

1 Like

@nat the previous error is not longer there, but now I cannot open any provided demo scenes and get hit with:

Cannot open scene at path Packages/litho-beta-2019-12-16-v0-6-0/Demo/LithoShowcase/LithoShowcase.unity. Maybe the scene hasn’t been imported. This can be done with an AssetDatabase.Refresh() call.
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Moving the Demo folder into Assets resolves the issue, but Litho still does not seem to control any demo scene.

After reading the docs, I expect the following flow:

  • Setup clean project on Unity 2019.3+
  • Add Litho SDK to Packages
  • In Unity do Menu > LITHO > Project Setup > Configure for Android (or iOS) [assuming either should be ok]
  • Pair Litho using Bluetooth Devices in system settings
  • Once pairing is done, launch Unity, navigate to LithoShowcase or Haptics scene
  • Disable GameViewController on Litho prefab responsible for the in-editor simulation of the device
  • Run the scene, ignore the “Searching” copy in the UI
  • Litho should immediately be available and control the pointer

Is this the correct sequence?
I can run all of the above successfully on 2019.2 except the last point (Litho is not working in the end), no errors are thrown in console.
In 2019.3.0f3, I get hit with the above error. Moving Demo folder to Assets allows me to run, but Litho doesn’t work.

1 Like

Hi @alex,

:wrench: - We’ve got a quick fix for you here (this will be included in a future release):

:one: - Open Packages/Litho SDK Beta/UI/Prefabs/LithoUI.prefab

:two: - Expand LithoUI -> DropdownMenu

:three: - Enable the Content GameObject

:four: - Save the LithoUI prefab

Let me know if this solves your issue :slight_smile:

1 Like

Thanks @lewis, will confirm as soon as I get a chance to test.